E-mail replies to Outlook.com users can end up in shopper's Spam inbox
Incident Report for ROBIN
Resolved
The warming up process is fully finished and all new servers are operational. Since Friday June 14th mail was delivered as expected in the regular inboxes. We monitored the process whole weekend and have done several tests which resulted in positive signals.
To prevent this from happening again we are preparing some additional changes in our setup. We will inform you as soon these steps are prepared.
The de-activated notifications are ready for activation again before Friday June 21st. Users who had used this feature recently, will be informed separately.
Posted Jun 17, 2019 - 09:36 CEST
Identified
Our investigation has resulted in the insights we were looking for.
The following steps have been executed:
-Sendgrid configuration changes
-Added two new mail servers to spread outgoing e-mail
-Fully stopped the e-mail notifications
Root cause of the current Outlook.com reputation is a result of the above three items.

New mailservers need warming up, as they need to build up positive reputation. As soon as the warming up is finished we can spread all the outgoing mails on these servers.

The first new server will be taken into production on Monday, June 17th, 9:00am CET or as soon as Sendgrid approves this.

We will keep pushing to resolve this issue as soon as possible and will provide an additional update here when we have any news on this incident.

Do not hesitate to reach out if you have any questions in the meantime.
Posted Jun 13, 2019 - 18:15 CEST
Update
Our investigation has resulted in the insights we were looking for.

The first configuration changes in Sendgrid have been made. New mail servers are warming up, which is needed to resolve this issue.

Next step is implementing the warmed up servers. We expect these servers to be in production before Monday, June 17th.

We're pushing to resolve this issue as soon as possible and will provide an additional update here tomorrow before 12.00 CET.

Do not hesitate to reach out if you have any questions in the meantime.
Posted Jun 13, 2019 - 12:01 CEST
Update
New data collecting instruments have been added to further investigate the issue. Tomorrow we expect to see the first results of switching off notifications.

Next update will be provided here tomorrow at approx. 12.00 CET, or as events warrant. Should this leave you with any questions, then please feel free to contact us via support@robinhq.com or by clicking the question mark in the top-right corner of the ROBIN app.
Posted Jun 12, 2019 - 17:44 CEST
Update
We are still investigating this issue. Next update will be provided here at approx. 18.00 CET, or as events warrant. Should this leave you with any questions, then please feel free to contact us via support@robinhq.com or by clicking the question mark in the top-right corner of the ROBIN app.
Posted Jun 12, 2019 - 14:22 CEST
Investigating
We are currently investigating an issue where e-mail replies sent from ROBIN to Outlook.com users (including Hotmail & Live) can end up in the shoppers’ spam inbox. The issue is a result of an incorrect reputation score at Outlook.com of one of the outgoing mail servers running at Sendgrid.

We are working on solving the root cause.

Important suspect in this situation is the ‘e-mail notification feature’ that allows ROBIN users to get notified via e-mail when a new messages lands in their inbox. We therefore temporarily de-activated this feature, at least till tomorrow, Wednesday June 12th 1:00pm (CET).

Unfortunately the reputation at Outlook is not something that can be fixed instantly, so next update will be done tomorrow, Wednesday June 12th before 10:00am.

We are sorry for the inconvenience.
Posted Jun 11, 2019 - 16:33 CEST
This incident affected: Outgoing Mail.