Small delay on incoming emails
Incident Report for ROBIN
Resolved
This incident has been resolved.
Posted 9 months ago. Oct 22, 2018 - 15:24 CEST
Monitoring
We are experiencing a small delay of 15 minutes in delivering incoming emails. Moving forward we structurally increased the capacity of these systems, and are monitoring the decline in the delay closely. We expect the delay to be mitigated within half an hour. And will resolve this incident then.

If you have any questions or if there is anything else, please reach out to our support team at support@robinhq.com or +31 85 877 00 23.
Posted 9 months ago. Oct 22, 2018 - 14:54 CEST
This incident affected: Incoming Mail.