Performance degradation - ROBIN Conversation Engine.
Incident Report for ROBIN
Postmortem

First of all, our apologies for the disruption this morning.

At 9:45 CET we noticed that the ROBIN application wasn’t performing up to par. Users noticed a slow and unresponsive ROBIN at times.

To restore performance for all users, we have scaled-up our technical infrastructure. As we continuously scale our Azure resources to demand, this was our first go-to remediation. Unfortunately, this process took much more time and effort than we expected.

Around 11:40 CET as a final step of this upscaling process, some parts of the ROBIN platform were restarted, which resulted in approximately 2 minutes of downtime for all users.

As of 11:45 CET performance was stable again for all users of the ROBIN application itself.

We are still looking into the exact cause of the degraded performance of this morning. Additionally, we are reviewing our remediation process as whole.

Again, our apologies for the inconvenience.

Posted 5 months ago. Feb 05, 2019 - 16:43 CET

Resolved
This incident has been resolved. Again, our apologies for the inconvenience.

If you have any questions, please reach out to our support team at support@robinhq.com or +31 85 877 00 23.
Posted 5 months ago. Feb 05, 2019 - 16:13 CET
Monitoring
We advise all users to refresh the application, in order to receive the newest updates.
While in ROBIN:
Windows: Control + F5
Mac: CMD + Shift + R

We fixed multiple issues and we are monitoring the results. The ROBIN app is performing stable again, but we are looking at this very closely.

If you have any questions or if there is anything else, please reach out to our support team at support@robinhq.com or +31 85 877 00 23.
Posted 5 months ago. Feb 05, 2019 - 11:54 CET
Identified
We are working on implementing a number of alternate solutions. The performance of the ROBIN app may vary from time to time, as we are rebooting parts of the platform. Please be advised not to refresh the application. Next update is due in 60 minutes. Our apologies for the inconvenience.
Posted 5 months ago. Feb 05, 2019 - 10:50 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. Feb 05, 2019 - 10:05 CET
Identified
We are in the process of taking measures, including partial restarts of the system. This may result in ROBIN not responding. Please be advised not to refresh the application. Next update is due in 30 minutes.
Posted 5 months ago. Feb 05, 2019 - 10:00 CET
Investigating
We are currently investigating a performance degradation of the ROBIN application. We will update you within 30 minutes, as we are working on remediating the situation. Our apologies for the inconvenience.

We are actively investigating this issue now and will post updates as soon as they become available. If you have any questions or if there is anything else, please reach out to our support team at support@robinhq.com or +31 85 877 00 23.
Posted 5 months ago. Feb 05, 2019 - 09:46 CET
This incident affected: ROBIN App.