Network connectivity issues Azure impacting ROBIN App, Widget and API
Incident Report for ROBIN
Resolved
This incident has been resolved.
Posted May 02, 2019 - 23:33 CEST
Monitoring
Between 22:07 (20:07 UTC) and 23:05 (21:05 UTC) ROBIN App, Widget and API may have experienced a partial outage due to connectivity issues at Microsoft Azure. The issue is now marked as resolved on the Azure Status page https://azure.microsoft.com/nl-nl/status/.

Background from the Microsoft status page:

Network Connectivity - DNS Resolution

Summary of impact: Between 19:43 and 22:35 UTC on 02 May 2019, customers may have experienced intermittent connectivity issues with Azure and other Microsoft services (including M365, Dynamics, DevOps, etc). Most services were recovered by 21:30 UTC with the remaining recovered by 22:35 UTC.

Preliminary root cause: Engineers identified the underlying root cause as a nameserver delegation change affecting DNS resolution and resulting in downstream impact to Compute, Storage, App Service, AAD, and SQL Database services. During the migration of a legacy DNS system to Azure DNS, some domains for Microsoft services were incorrectly updated. No customer DNS records were impacted during this incident, and the availability of Azure DNS remained at 100% throughout the incident. The problem impacted only records for Microsoft services.

Mitigation: To mitigate, engineers corrected the nameserver delegation issue. Applications and services that accessed the incorrectly configured domains may have cached the incorrect information, leading to a longer restoration time until their cached information expired.
Posted May 02, 2019 - 23:15 CEST
Investigating
ROBIN App users experience connectivity problems due to general connectivity / DNS issues in our Microsoft Azure Datacenter (see also https://azure.microsoft.com/nl-nl/status/). In 60 minutes or as soon as a solution will become available we will provide a new status update.
Posted May 02, 2019 - 23:02 CEST
This incident affected: ROBIN App, ROBIN Widget, and API.