Delay outgoing mail
Incident Report for ROBIN
Resolved
Email delivery at our outgoing mail processor has returned back to normal for a while and a root cause fix is on the way to mitigate some final issues at their datacenter. We believe our own service has hardly been impacted by their service disruption today. This incident is now considered resolved.
Posted Jul 28, 2020 - 21:40 CEST
Identified
Due to a major outage at our outgoing mail processor, you may experience delays in outgoing mail delivery. We are closely monitoring their progress as they work to mitigate their issues.
Posted Jul 28, 2020 - 15:30 CEST
This incident affected: Outgoing Mail.