Performance degradation
Incident Report for ROBIN
Resolved
We have closely monitored the app for a full week following some days of instability. No further issues occurred. This is now considered fully resolved.
Posted Sep 23, 2019 - 10:20 CEST
Monitoring
We have taken additional measures to further stabilize app performance. We will monitor the impact throughout the day. Though some engineering work will continue in the background, we are hopeful we can do so without issues arising.

Thank you for keeping track of this page for updates as we worked to resolve this.
Posted Sep 17, 2019 - 08:27 CEST
Update
We have as of yet not reenabled any of the remaining disabled functionality. We will also not do so until we are fully confident that it will not cause performance issues.

Please find support for any questions we may have left you with at this moment.
Posted Sep 16, 2019 - 13:54 CEST
Update
We are fully up to date on e-mail. Our queues are empty.

The app is still stable. We will slowly and carefully reactivate disabled features throughout the day.

Next update in an hour at the latest, or as events warrant.
Posted Sep 16, 2019 - 12:34 CEST
Update
Here's an update on the queue on inbound e-mail:

The oldest item to be processed is of approximately an hour and 15 minutes ago. As we are now processing this at full capacity again, we can estimate when we will be realtime on e-mail again.

Please note that this calculation is working on the assumption that no new issues arise. Under those circumstances, we should have emptied the queue in about 45 minutes.

Thank you for your patience and understanding as we continue to work hard to fully resolve this.
Posted Sep 16, 2019 - 11:47 CEST
Update
Performance has continued to stabilize further. We've worked up a significant queue on inbound e-mail during mitigation. This is now being processed at maximum capacity again. We will update you on both the status and expectations of this queue at approximately 11.45

All other measures remain in force until we are comfortable with the performance levels we are seeing.

Next update at approximately 11.45, or as events warrant.
Posted Sep 16, 2019 - 11:30 CEST
Update
A subset of ROBIN users has been experiencing degraded performance. We have taken various measures to stabilize the app. Though we see improvements, we haven't managed to find the root cause yet.

For a subset of ROBIN users, "My inbox overview" is not functioning.

The following measures have effects for all users:

- Inbound e-mail is facing some delays.
- The search results in ROBIN are not fully up to date as of this morning.
- Pinned messages are temporarily disabled.

Our apologies for this. Please find support should this leave you with any questions.
Posted Sep 16, 2019 - 10:06 CEST
Update
Some chats may have arrived in your inbox with delays. This should stop occurring. New message indicators have been fully disabled (temporarily) to mitigate the performance issues we are seeing. We are continuing to investigate the root cause of this issue. Next update in 30 minutes at the latest or as events warrant. Our apologies for the effect this has on your work today.
Posted Sep 16, 2019 - 09:30 CEST
Investigating
We are investigating a performance degradation. We will update within 30 minutes
Posted Sep 16, 2019 - 08:57 CEST
This incident affected: ROBIN App.